Collection Of Issues/Feedback

I love the product / idea, but have run into quite a few problems as I’ve used it at the DZ. I’d like to preface the notes below by saying that all jumps have been with a wingsuit. I’m happy to provide any additional detail / data related to the bullets below that is useful in issue resolution - just let me know.

  • Logs not syncing (believe this is a known bug)
  • Logs deleted/missing from device before upload (device was unresponsive/lagging after landing, noticed upon gear up for next jump, power cycled device to restore normal behavior and the previous jump went missing)
  • Poor reporting/performance while wingsuiting (inaccurate deployment altitutes, have to go back and mark jumps as wingsuit)
  • GPS lock is sporadic (I don’t have similar issues with the FlySight for example)
  • Device will not charge while powered off
  • Device will not reconnect to WiFi at the DZ post jump
  • Device will not upload logs on “poor connection”
  • Device buttons do not work (ex: review jump after landing)
  • Back button does not take me to the screen I was at previously
  • Wrist strap is of poor quality (splitting at the edges, usb inaccessible while in strap, power difficult to use while in strap)
  • Screen constantly in random places due to contact with gear / airplane / whatever - a lock is needed badly to prevent accidental action

Final thoughts:
I want the product to succeed, but am overall disappointed with the initial release, lack of polish, and slow updates given the price tag. Another year of testing / R&D would have made a world of difference. At this point in time I’m unable to recommend the alti to anyone else at the DZ.


We have to remember, it’s a explorer version.
Let me guess, it’s a kind of crowdfunding…

Think the developer will do there best to bring this idea to a great product.
I tried the alter altimeter… good idea but very poor service.
Dekunu offer us this community.

What I don’t understand, there are some bugs they have to be seen at the beta testing period.
I do recommend it on my dropzone regarding to the possibilities and roadmap. Think this idea has the power to change the altimeters in our sport like the iPhone changes the mobile phones. But it will take time.
Let us give this time to dekunu. Hope to be NOT disappointed…

And thanks Tracy for updating the dropzones…


Hi @psch sorry to hear you are feeling a bit disappointed - I’ve sent you an email to start a conversation with you about it and address some of the points you bring up. Thanks so much for providing your thoughts and feedback, we are really appreciating all the input from the great community of users.

@psch The new firmware which has just been released has fixes for all of your concerns with the exception of the last two. Hopefully this demonstrates the Dekunu teams’ commitment to the progression of this device and plays a part in changing your mind about recommending to your friends.
Apologies for the delay in releasing the fw, testing of each new fw update can be quite time consuming and a lot of the time weather dependant.
To cover the last two points you made - re-designing of the wrist mounts is underway, posts like yours and feedback/suggestions from other users on this forum have been invaluable to the development of the device and accessories, any and all comments are taken on board and kept in mind when designing hardware or implementing new features. I will add the ‘lock screen’ feature to the future development list, you can check out the suggestions from other ‘Explorers’ here
You will be happy to know we are in the final stages of designing the wingsuit mount too :slight_smile:
Thanks for your honest feedback, it is much appreciated (and keeps us on our toes!)

1 Like

I do not believe the log upload was corrected. At least I am not seeing. “Poor connection” is not an issue as I have been on a 10Gb unfiltered Internet connection with no success. I think if that was not resolved in the latest update is a huge setback. For me uploading logs is primary.

1 Like

@tharshman can you do a reset on the device and reconnect to internet for me please?

I must say, I also still have 1 log from April on my device that still needs to be uploaded to the cloud.

1 Like

@stirre did the rest of the logs upload for you? Could you try doing a test to see if that pulls it over?

All my other logs in my device where always uploaded automatically, except for this one from april. I am sure i did mention it already.

I didn’t jump after the update yet and yes, i can do a test.

1 Like

@stirre I am interested to see if it works, if not I will trouble shoot with the tech team in the morning and see what we come up with


What kind of test? Just the reset or something else?

Try resetting and leave it connected to wifi for a half hour or so, if that doesn’t work try ‘switching user’ to re-log in to the device. Let me know how you go


I tried both test - but still the one log of 21-4-2018 that doesn’t upload to the cloud.

Also the device shows at diagnostics/logs: 0 logs to sync

1 Like

Thanks, I will check it out. Could you send me the jump logs folder from your device? Zip the folder and email to I will figure it out tomorrow. Thanks again! @stirre

I will do. The strange part is: it’s log number 5, but in my device, there are only 3 logs before number 5.

1 Like

I appreciate the firmware update. I will provide feedback re: fixes as soon as possible. I’ve got quite a few jumps planned in the coming weeks. Looking forward to seeing what the team comes up with on the wingsuit mount. I’m happy to help test it out if you’re in need of wingsuit testers.

1 Like

Thanks for your kind offer @psch and I look forward to your feedback, we have heaps of new features lined up for the Cloud platform in the coming weeks too

Yeah not much change on the log portion from this update. I did everything. Twice…three times to get to resolve. It is not fixed or more so consistently fixed. I still have 11 queued from last weekend. Wonder what this update really did that was substantial? The list of fixes does not seem accurate.

1 Like

So now I have reached a point of complete disappointment and lack of trust. We are not going forward but backwards. This update has cause such abnormal behavior and not much I can do about it other than reset 20 effing times. Now wireless is completely non-functioning and without that pretty much not shit you can do! It won’t scan wireless as it says either inactive or disabled. It connected briefly for about 30 seconds and is now back to disabled. My device was working more reliably before this update. Now I have invested about 3 hours since this update trying to get something to work. From the list above, 80% of that list is still broken. The only thing I have not done is login as me again and can’t cause you need wireless to do that. I am about ready to box this up for now as it gets me so agitated I can’t see straight.

1 Like

We can back rev can’t we? I have all the builds and want to go back to 3.5.2 at this point. Can I just reload the file in USB mode and reload an older FW. How does that play out on this device?

1 Like