Time display is offset for DZ

I’ve had this issue at a couple DZs where the time is off by an hour because of the GMT offset. I’m currently set to Skydive Sussex (in New Jersey) and it is set to one hour earlier than it should be. I’m pretty sure this is happening because of the daylight savings time switch.

Could someone please adjust this?

What would also really help is if the next firmware update allowed a manual time adjustment setting.

Thank you!

Hey @torkuno this has been fixed up for you, next time you power the device on and connect to wifi, go into the dropzone settings tap ‘change dropzone’ and refresh the list by tapping the button in the top right corner of the screen. The time will update automatically :slight_smile: