Seems to be failing more and more

Well I did get mine from the very first batch. However, seems to be failing quite a bit now. It acts flaky though my cover is just a tad loose and popping up a very tiny bit around the charging and status ring light. The tapered end. However, orange and green screens requiring hard reset in rest hole and this pic today which won’t go away and now resetting does not find SD card and ends up here and locked.

Yeah so took it apart and pulled the battery and removed SD card. Took pencil eraser and buffed the contacts and cannot get this thing to recognize the SD card. Same error as if you booted it without the card in. Everything else is in great condition. Maybe since his thing is not sealed and that millimeter of compromise I had on mine contributed to some moisture damage. If unrecoverable not sure I will get another one. We’ll have to see.

I can read the card on my computer so card is good

Okay another UPDATE:

  1. Card read on computer had one file (image file) named abcd
  2. I put in another card from a GoPro and it mounted though did not have image on it so it went the blue screen with the cross hairs on it. This was expected
  3. put original card back in altimeter and it does mount now and still goes the screen in original post except this time I get functional beeps.

I was going to try and reimage but won’t see card though it now mounts the card and is trying to load the firmware

@tharshman thanks for posting, I think it would be best to send your device in for analysis. If the enclosure is damaged we can replace that and give the unit a good service for you. If you would like to send it in please shoot me an email to and I will give you the address and instructions :slight_smile:

Send back to AUS or somehwere in the US? Hmm, I guess. Isn’t that going to have cost implications for tax and shipping and such?

The email has been sent

We have a maintenance station in the US, I have replied to your email with details.

You/re the best. However, it is the card that is bad. I try to format it and it failed with errors. So I took one of my GoPro 32 Gb cards and formatted as FAT and transferred my friends Dekunun SD card files over in entirity and it worked. Booted up requested USB connection to activate and then logged in as my friend. Of course it had the “switch user” option so allowed me to switch to me. I am still going to send it in as I bought a new one yesterday. So now I will have two or sell one.

1 Like

I AM BACK! No jumps on there but wonder if they can be sync’d with the cloud?

1 Like

FYI for anyone following this thread - the safety override screen is a safety feature of the One, if a hardware problem is detected the device will shut down any non-essential functionality, the altimeter will still work for obvious safety reasons.
The error display in this case showed that the SD card was at fault, this is an easily replaced part, we have maintenance stations in the UK, USA, New Zealand and Australia who can take care of this.
It is not recommended to take the device apart and exchange any parts yourself unless approved by Dekunu to do so, in this particular instance Tom is one of the first Explorer users and is familiar with the hardware.
If you experience this error, please email to request an RMA.


Yes and spent my earlier years taking tech items apart. I was in PCB design of hardware years ago so was always inside tech. Don’t recommend going into yours as opening unecessarily puts device at more risk of foreign materail entering the device, excessive moisture if not in a anit-static the PCB could short handling it and then it will need replaced and the casing will not even sit like it does during the manufacturing process and therefore like mine may be a bit compromised in a good seating of the cover. That’s my take. Plus mine dropped the first week I got it in 2018 and therefore got a good view of the device and its design and construction. Otherwise would have never opened it to begin with.

1 Like