Not showing or showing incorrect freefallspeed and canopy speed

Having problem with incorrect speed in freefall and under canopy, have tried to upload jpgs (is attached) showing examples, have had this problem since first jump.

Also having problem syncing jumps to the cloud, only 4 out of 15 are synced.


Same here. Speeds are incorrect.

I found that only the exit altitude and almost always (not always always) freefall time are correct.


Hey guys,
The speeds on the device are incorrect right now, most of our efforts have been in the accurate collection of data and the back end system (Cloud), the algorithms will be worked on going into the future. This is among our top priorities now the latest firmware has been released so stay tuned :slight_smile:

Me too. I expect it is a filtering problem with the data. A simple low pass or moving average filter can get highly corrupted by a small number or even a single large outlier. I would guess that might be happening here. If so, they probably need to employ a more complex filter technique such as local regression smoothing.

1 Like

I noticed that after synching the data on the alti is more accurate, but speeds remain inaccurate even on the website

1 Like