Frozen, won’t respond to screen/button presses - SOLVED

I just finished activating and updating firmware and it will not respond to screen press nor holding down the power button. I can reset and it will reboot back to the home screen but the frozen non responsive behavior persists. I have successfully connected to my WFI during the activation and firmware update without issue

Hi Nathan,

Just to clarify did you say that you had reset it and everything was back to normal afterwards?


No, I reset it and it boots right back to the home screen and is locked up and not responding. I’ve tried resetting it several times with no luck

Hey Nathan,

Sorry to hear that. We have a couple of options to see if we can address this problem but, please bear with us while we sort through the best approach.

When you reset the device, you should see a green screen that shows versions of your software; would you mind posting them here please?


Hi Nathan,

Could you try resetting your device out of range of your wifi? We’re seeing calls to the API that stop after a certain point (where they should continue) so, we’re trying to figure out if there’s some networking issue or something else going on.

Please let us know,

Hi Dan
Hi have the same problem, I try to reseting out of ranger of wifi and still frozen like Nathan pic. what I can do ?

Trying out of WiFi range yielded same result

1 Like

I have the same problem. Connected to Wifi and logged in and now it’s froze on the home screen and wont turn off. I can only reset…at which point it comes back to main screen where the frozen condition continues.

Thank you everyone for bringing this to our attention. I’ll refer it internally.

@joshp14 @christianbicker could you also paste the versions your device is using.

Thanks very much for working with us on this.


1 Like

Same as Nathan’s.

1 Like

Consistency is good here, even if the issue isn’t great.

Thanks again,


Any updates for the frozen issued ? My device is super hot and won’t torn off

@christianbicker just heading into the lab now, I will get you an update ASAP.
apologies for the delay, the time difference isn’t in our favour right now

Any update? Mine stayed on until it died. As Christian stated, mine got fairly warm too when it was on.

1 Like

Hey @joshp14 - we are currently testing a firmware update that should fix all freezing issues, we have a test jumper in the air right now :crossed_fingers:

@joshp14 @christianbicker @Nathan see below

How do we set our device into USB mode if it is unresponsive to any input?

Hi @Nathan - you can hold down the power button, tap the reset button and then after a couple of seconds release the power button

1 Like

Hi Brent,
I want to make sure I’m doing the right thing here, first I have to charge my Device then I hold down the power button, tap the reset button (is the little hole that can use with a clip?) and then after a couple of seconds release the power button but still holding the reset bottom?
After all this :point_up:t2:I connect to my computer ?