First Day Issues

Just got my Dekunu, activated it, turned it on at the DZ and the screen froze. Tried resetting it once and it froze again. Tried shutting it off and the screen would not work- so I could not select yes to turn it off. Resent again and now it has an SD Card read error. Did not even get to jump it once. The screen also looks like it has some issues. When you touch it it flexes and the crystals in the screen darken. So far, rather disappointed.

As you’re coming in a bit later than all of us, you might now have seen all the updates that dekunu release. I can assure you a lot of bugs have been solved and the alti is working pretty well.
The first thing I recommend you is to upgrade the firmware if you haven’t done it yet. It should detect it automatically wen you connect to wifi or in alternative you can upgrade it manually. There are several guides on this forum on how to do it.
I hope your experience will improve because I’m a quite happy user like many of us here!

I activated it yesterday, and it upgraded the firmware as part of the activation process. This is after a month delivery delay. I have a PHD in aerospace engineering and a masters in computer and electrical engineering. If it was an easy fix, I am sure I could have figured it out. :):sunglasses:

Thank you very much on the advice, though. Even smart old dogs can learn new tricks. I will double check the forums again.

Going to look and see what is on the SD Card next.

Looked at the card. My user profile is on there?

I think it is not looking for my file though…

I realized it was flashing another screen on bootup really quickly, so I did a burst capture and found this…

I am going to look through some of the files and see if I can figure out where it is looking for the user files…

I noticed there is no deviceConfig.json file on the SDCard? I never even looked at what is on the card prior to this, so not sure what happened to it.

Can I just copy my current user file to userProfile_0.json at load it? Then force a user change to my original user profile? I may try that… I am guessing some wifi or cloud synch issue?

I have looked through all the system logs and (assuming I am looking at the correct one, It says this)

Read system config: system/config/systemConfig.json
[ 13101][====][0x200085d0/mainTask][INFO][CONFIG] jsonMapCfg_read: read json: system/config/systemConfig.json
[ 13114][====][0x200085d0/mainTask][INFO][CONFIG] System config read successfully
[ 13127][====][0x200085d0/mainTask][ MSG][COMMON] REST SRV:
[ 13133][====][0x200085d0/mainTask][ MSG][COMMON] REST API: /v1/
[ 13143][====][0x200085d0/mainTask][ MSG][COMMON] MQTT :
[ 13151][====][0x200085d0/mainTask][ MSG][COMMON] Cur mem free: 226776, 208408
[ 13163][====][0x200085d0/mainTask][ MSG][COMMON] Read DeviceCfg
[ 13172][====][0x200085d0/mainTask][INFO][CONFIG] Read device config: system/config/deviceConfig.json
[ 13182][====][0x200085d0/mainTask][INFO][CONFIG] jsonMapCfg_read: read json: system/config/deviceConfig.json
[ 13202][====][0x200085d0/mainTask][ ERR][FILE] fileOpen: {C:\dekunu\dekunu_src\file.c, line 294}: Can’t open file ‘system/config/deviceConfig.json’ with mode=0x01: [4] Could not find the file
[ 13222][====][0x200085d0/mainTask][ ERR][CONFIG] jsonConfig_readFileToBuf: {C:\dekunu\dekunu_src\json_config.c, line 42}: Can’t open config file ‘system/config/deviceConfig.json’
[ 13238][====][0x200085d0/mainTask][ ERR][CONFIG] jsonConfig_read: {C:\dekunu\dekunu_src\json_config.c, line 134}: Failed to read JSMN-config 'system/config/deviceConfig.json
[ 13254][====][0x200085d0/mainTask][ ERR][CONFIG] jsonMapCfg_read: {C:\dekunu\dekunu_src\json_map_cfg.c, line 64}: jsonConfig_read failed
[ 13269][====][0x200085d0/mainTask][CRIT][COMMON] jsonCfgDeviceConfig_read: {C:\dekunu\dekunu_src\json_cfg_device_config.c, linCan’t read device config
[ 13280][====][0x200085d0/mainTask][INFO][SCREEN] Popup with confirmation:Failed to read DeviceCfg from SD-Card
[ 13286][====][0x200085d0/mainTask][ MSG][COMMON] DEVICE_ID: 0
[ 13293][====][0x200085d0/mainTask][ MSG][COMMON] Cur mem free: 226024, 208408
[ 13308][====][0x200085d0/mainTask][ MSG][COMMON] Read UserProfile
[ 13316][====][0x200085d0/mainTask][INFO][CONFIG] Create empty user profile for guest
[ 13325][====][0x200085d0/mainTask][INFO][CONFIG] Guest user profile created successfully
[ 15029][====][0x200085d0/mainTask][ ERR][FILE] osDir_open: {C:\dekunu\dekunu_src\os_dir.c, line 162}: Can’t open dir: jumpLogs/complete: [5] Could not find the path
[ 15037][====][0x200085d0/mainTask][WARN][FILE] can’t open directory jumpLogs/complete
[ 21976][====][0x200085d0/mainTask][ ERR][FILE] fileRename: {C:\dekunu\dekunu_src\file.c, line 559}: Can’t rename file /tmp/userProfile_0.json.tmp to system/config/userProfiles/userProfile_0.json: [4] Could not find the file
[ 21989][====][0x200085d0/mainTask][WARN][FILE] Can’t rename file from /tmp/userProfile_0.json.tmp to system/config/userProfiles/userProfile_0.json
[ 22002][====][0x200085d0/mainTask][WARN][CONFIG] Can’t rename file from /tmp/userProfile_0.json.tmp to system/config/userProfiles/userProfile_0.json
[ 22012][====][0x200085d0/mainTask][ MSG][COMMON] Cur mem free: 225376, 208408
[ 22024][====][0x200085d0/mainTask][ MSG][COMMON] Read Wifi Json
[ 22032][====][0x200085d0/mainTask][INFO][CONFIG] Read wifi config: system/config/wifi.json
[ 22042][====][0x200085d0/mainTask][INFO][CONFIG] jsonMapCfg_read: read json: system/config/wifi.json
[ 22053][====][0x200085d0/mainTask][INFO][CONFIG] Wifi config read successfully
[ 22060][====][0x200085d0/mainTask][ MSG][COMMON] Cur mem free: 225208, 208408
[ 22083][====][0x200085d0/mainTask][ MSG][COMMON] espTask_init

Hi @batesal1 I’ve seen Tracy is helping you out via email, thanks for sending through your feedback :slight_smile:

No worries!

Thanks, Angela.