Error: sd fail

@Tracy I have the ERROR: SD FAIL and I’ve emailed How long for a response? Does this always take an email to fix? Are there no procedures that can be posted in the forum?

I removed the sd card and tested it on my computer. The card was readable and the files were intact. So I made a copy of the files. I then transferred the files to a newly formatted (FAT32) sd card. A hard reboot, battery disconnected, install sd card, reconnect battery, power on. The unit booted up normally and worked perfectly.

I then performed the firmware update requested by the device and it succeeded.

Device is functioning well now.

Note that the new sd card is a little thicker and I also applied a small label to it that adds slightly to the thinkness. This card fits the card slot in the device much better. The original card is very thin and actually somewhat loose in the card slot, this may be why it was not being read.

1 Like

Hey, Vic.
I have exactly the same problem. Sent an email to tec support but still no response.
Where did you find sd card? I’ve disassembled the device but found nothing.

The SD card is in a silver housing on the back of the board beside the battery. I’d send pictures but I’m away from the DZ until Friday.

@OneKil0 please respond to Mike on the email thread you guys have going and he will show you how to do the replacement and reassemble the device. If care is not taken you could damage internal components