Device not holding charge


I’m charging my unit and when plugged in it shows the charging symbol but zero battery level, as soon as I unplug it the device shuts down. I’ve tried two cables and have it out the bumper casing so I’m sure the cable is in properly, I’ve also tried a reset and left it charging overnight…any ideas?



My latest theory is the Dekunu somehow manages to brake/destroy the usb cable.

Hey @evilgenius, with it plugged in to your charger, can you open up the Battery page in diagnostics and post a pic/what it says in this thread

After restarting when plugged in it initially shows 0% SOC, then after 30 secs or so switches to 87% SOC (pics attached). Every few mins it cycles between the two readings. When it’s unplugged it immediately powers down and when plugged in again returns to 0% SOC and the cycle begins again.

1 Like

@Evilgenius If it immediately powers down when off charge, the battery may have come loose somehow. I will send you an email and we can troubleshoot to try to solve this :ok_hand: