Broken unit (again) after quarantine startup

I know you guys set the bar low when it comes to reliability and having trust in the unit, but this is getting way out of hand.
As I anticipated a bad startup of the unit (go figure), I already charged the unit after 2 months of being grounded because of COVID-19. Add a couple of extra months and we’re now today.
Wanted to boot, unit had no battery (as expected), plugged in to charger. Start booting, and rebooting, and booting and rebooting till nothing. Left it overnight and came back to a rave party of the 90’s with the flashing screen.
Critcal SD error (again). Had it serviced before.
Have video if interested.

Dekunu is expensive piece of equipment due to the fact I have to have a 2nd atltimeter of a trusty and working brand as a backup (read: main).
Pro tip for all possible buyers, if you want to do it for the data, save yourself the frustration, time and cost and get a Viso and a FlightSight.
I can’t defend the product anymore, which I did after many setbacks.

I wish I had bought a Flysight instead, I would actually have some usable swoop data.

1 Like

(Ow yeah, after being ‘charged’ for a night, battery is still at 0% shutting down the unit withing seconds)

Update on the issue
Tried different data/charging cables, was finally able to charge it without flipping & rebooting.
Jumped with it this weekend (+ a backup unit) without any problem (besides the known poor battery life)
Still weird the unit flipped during 2 days rendering it useless.
Also keep on getting a warning “found fw image for different hw revision”

There are 3 different hardware versions, if you tried a FW update manually, it could be that you have a file for a wrong hardware version on your device

@grtlns If you are having charging issues it is most likely that either the cable you are using is broken or the outlet is not providing enough power to charge the battery. Glad to see you figured that out and got it working.
Can you clarify what you mean when you say the unit “flipped”? I am guessing powered on and back off?
If your device has been powered off for an extended period and the battery is completely drained it does take a little time to charge, this is a safety function of LiPo batteries, they trickle charge to prevent damage to the cell. The most efficient method of charging your device from 0% battery is at a strong power source such as a wall socket, not from a USB port of another device. I know you already sorted this but just for clarification for anyone else reading this post.
The error message you are receiving is related to firmware as Joe mentioned, I will send you an email with the correct files and instructions to get you going.

I didn’t install any firmware, it was sent to maintenance and came back -as is-

Battery
I assumed it wouldn’t work after a prolonged period of downtime. I did however, charge the unit without any problem some months ago to counter this problem. Little did I know this covid-19 situation lasted longer expected, so battery was fully drained by the time our DZ’s opened up again.
During initial charging, the unit rebooted a couple of times, didn’t think much of it as I assumed it had to do with the empty battery etc. It kept on rebooting, and I left it to charge overnight.
See video for the result I woke up to.
Battery was still on 0% it seems.
In the end I used some other cables as mentioned, and finally the battery charge % went up on the display (was not an issue before with the same cable last season)

‘flipping unit’
2 video’s, showing the flashing screens, random heights/errors


Uploaded the logs after this issue as well to the cloud

If you need more info, let me know.
Unit was working fine after I fixed this charging problem. Alti was correct, no reboots as before during climb or freefall

1 Like

@grtlns thank you for clarification and for uploading your logs, I will pass them on to the development team for investigation