🔔 🪲 Device Firmware Release - v3.7.2 (2018-06-11)

The next firmware release is now publicly available!

There are some big changes, new features, bug fixes and stability improvements. Our biggest release yet and the biggest internal changes which is why we hadn’t released for a while.

This release includes changes from 3.5.3, 3.5.4, 3.6, 3.6.1, 3.6.2, 3.6.3, 3.6.4, 3.7 and 3.7.1 - each of these versions were tested with our test jumping network but were not polished enough for public release. v3.7.2 has been jumped over 100 times and is super stable. We can’t wait for you to have it.

Here is the high level change log, enjoy:

  • ability to stop live action if incorrectly started (i.e. when driving a car)
  • device now reverts to Plane Mode after incorrect Jump Mode starts (after a plane levels out for hop & pops then re-climbs)
  • device to continue action mode if accidental reset occurs
  • added ability to charge device while switched off
  • changed name on home screen from full name to nickname
  • fix for jumplogs going missing
  • just landed review button fix
  • fix for log book date suffix
  • improved password handling for user switching
  • user stats improvements (no more million mile jumps)
  • fix red screen of death bug
  • improved GPS performance after initial boot
  • if GPS signal not found after boot, keep retrying in low power mode each 15mins
  • additional components put to sleep when not used to save power
  • lots of refactoring, bug fixes, additional diagnostic logging and performance improvements

Please report any nuances, bugs, odd behavior etc to support@dekunu.tech


Is it possible this FW messed with the time?

I just did the update almost half an hour ago, after it, I get XX:XX and after 30 min it is still remaining like that.

@stirre The time comes from GPS, take the device to the window or even better outdoors so it can pick up some satellites, let me know how you go :slight_smile:

1 Like

can we get link to file? (never mind from my side, the update worked via device settings)

Where is the firmware file??

So you are saying this one actually worked from the FW upgrade on the device itself?

yes, it failed to update twice, I restarted it (pin reset) and then tried again and it did the update after asking to install it.

1 Like

Here is the manual download link for anyone that needs:


First, thanks for the update and for working hard! I’m looking forward to testing the new improvements

Even after the update I still have many inconsistencies in my log book, including stats (times, speeds, yesterday 6 mintues of freefall). Because it seems the update didn’t fix some more problems I encountered, I report the questions I asked in another topic:

Will jumps that are not displayed in the log book reappear?
Will I be able to synch the jumps on the device but not on the cloud?
Will jumps that are on the web UI but not on the device synced?

I’d like to know if there is a solution for these problems/if you are planning to fix them.


Significant improvement. Only notable issue today was a hardware error screen at 900ft with a restart… however it rebooted quickly and read the correct altitude.

1 Like

What about the dozen jumps that are stuck queued up. When are they going to load to Cloud? What are next steps?

1 Like

Hey guys… just downloaded this. Firstly, thanks for turning it around!

It took me quite a few (at a guess, 5 or more) goes to get the firmware loaded… it would go to download and fail.

Once it did download, had some weirdness with the wifi.

  • Couldn’t connect to wifi. Click “Scan” -> Scan would happen for a little while -> Reset to home screen. If you go back into connect/scan again, it would flash the screen with something unintelligible and refused to scan.

Only fixed after another ~10 reboots.

Everything seems OK other than this, but I do still have some log book entries “stuck” on the device. Will have more feedback after the long weekend jumping.

1 Like

@gemhodges I updated Jill’s device for her at the weekend and her logs took a little while to sync just after the update, it could just be that, I will chat with you after the weekend and see how you went

@tharshman I answered you on another thread, can you try a reset to see if that gives them a boost?

Done that several times. Reset, on/off, in and out of wireless. I have not been able to login again as I forgot my password for the three digit numeric account. I will do one more reset. Then I am heading out for three days to Zhills to jump so should get about 15-20 jumps on it and will see how it works.

1 Like

I also left it one and wirelessly connected for over 24 hours now. Looking at the activity bar at the top it goes in and out of wireless and syncing though it is always connected to wireless. The two small icons at upper left that shows wireless symbol and sync symbol I am assuming seems like it is syncing cause it is “puslating” which to me would be like a data push or pull. When it goes to screen saver mode it puts big yellow exclamation marks next to those icons and whenn I tap it to wake it up it shows them for a second and then the wireless symbol comes on the the sync may or may not show the puslating icon. Right now I am wirelessly connected yet the sync symbol is inactive.

1 Like

Really seem to be trading off here. Now I have all sorts of odd behavior since update. Wifi seems completely hosed and indicates state = “inactive”. Scan and other functions seem to not bring it online. I have been in diagnostics and nothing. I need to get my password for my three numeric account so I can try logging out and back in.

1 Like

Use your password you use for your cloud. I think you can ask a new one at that page?

1 Like

Thanks. But the odd thing is you can’t log in or out of device with no network and right now since update and multiple resets per Tracy I now have wifi as “inactive”. Not sure what changes that state as there seems no controls to activate the NIC as like you do on a PC or laptop wifi adapter.

1 Like